MDH Lab – Switch Case Study

Topologi

lab4-3clean

Objectives

  • Plan and design the International Travel Agency switched network as shown in the diagram and described below.
  • Implement the design on the switches and router.
  • Verify that all configurations are operational and functioning according to the requirements.

Requirements

You will configure a group of switches and a router for the International Travel Agency. The network includes two distribution switches, S1 and S3, and two one access layer switches, S2. External router R3 and S1 provide inter-VLAN routing. Design the addressing scheme using the address space 172.16.0.0/16 range. You can subnet it any way you want, although it is recommended to use /24 subnets for simplicity.

  1. Place all switches in the VTP domain CISCO. Make S1 the VTP server and all other switches VTP clients.
  2. On S1, create the VLANs shown in the VLAN table and assign the names given. For subnet planning, allocate a subnet for each VLAN.
  3. Configure S1 as the primary spanning-tree root bridge for all VLANs. Configure S3 as the backup root bridge for all VLANs.
  4. Configure Fa0/4 between S1 and S3 as a Layer 3 link and assign a subnet to it.
  5. Create a loopback interface on S1 and assign a subnet to it.
  6. Configure the Fa0/3 link between S1 and S3 as an ISL trunk.
  7. Statically configure all inter-switch links as trunks.
  8. Configure all other trunk links using 802.1Q.
  9. Bind together the links from S1 & S3 to the access-switch together in an EtherChannel.
  10. Enable PortFast on all access ports.
  11. On S2, place Fa0/15 through Fa0/17 in VLAN 10. Place Fa0/19 and Fa0/25 in VLAN 20. Place Fa0/21-22 in VLAN 30.
  12. Create an 802.1Q trunk link between R3 and S3. Only VLANs 10 and 40 to pass through the trunk.
  13. Configure R2 subinterfaces for VLANs 10 and 40.
  14. Create an SVI on S1 in VLANs 20, 30, and 40. Create an SVI on S3 in VLAN 10 and 30, an SVI on S2 in VLAN 40.
  15.  Enable IP routing on S1 and S3. On R2 and S1, configure EIGRP for the whole major network (172.16.0.0/16) and disable automatic summarization.

VLANs:

  • Vlan 10 – Red
  • Vlan 20 – Blue
  • Vlan 30 – Orange
  • Vlan 40 – Green

Genomförande

Subnetting

Jag har som synes redan lagt in den subnetting jag gjorde i topologin men såhär ser den ut iaf: 172.16.0.0/16

Vlan 10 - Red 172.16.10.0/24
 Vlan 20 - Blue 172.16.20.0/24
 Vlan 30 - Orange 172.16.30.0/24
 Vlan 40 - Green 172.16.40.0/24

S1

Lo0 - 172.16.1.1/24
Vlan 20 - 172.16.20.1/24
Vlan 30 - 172.16.30.1/24
Vlan 40 - 172.16.40.1/24
S1-S3 Link - 172.16.13.1/24

S3

Vlan 10 - 172.16.10.3/24
S1-S3 Link - 172.16.13.3/24

S2

Vlan 40 - 172.16.40.2/24

R3

Vlan 40 - 172.16.40.200/24
Vlan 10 - 172.16.10.200/24

Med den information vi fått ovan kan vi uppdatera vår topologi lite:

Basic L2-konfig

S1 – Kom ihåg att S1 även ska vara Root-bridge för samtliga VLAN & VTP-server

Switch(config)#hostname S1
 S1(config)#line con 0
 S1(config-line)#logging sync
 S1(config-line)#!Trunk-links till S2
 S1(config-line)#int range fa0/1 - 2
 S1(config-if-range)#switchport trunk encaps dot1q
 S1(config-if-range)#switchport mode trunk
 S1(config-if-range)#description to S2
 S1(config-if-range)#channel-protocol lacp
 S1(config-if-range)#channel-group 1 mode active
 Creating a port-channel interface Port-channel 1
S1(config-if-range)#!L3-link till S3
 S1(config-if-range)#inte fa0/4
 % Command exited out of interface range and its sub-modes.
 Not executing the command for second and later interfaces
 S1(config-if)#no switchport
 S1(config-if)#ip add 172.16.13.1 255.255.255.0
 S1(config-if)#description to S3 L3-port
 S1(config-if)#!ISL-trunk till S3
 S1(config-if)#int fa0/3
 S1(config-if)#switchport trunk encapsulation isl
 S1(config-if)#switchport mode trunk
 S1(config-if)#description Trunklink to S3
 S1(config-if)#!VTP
 S1(config-if)#exit
 S1(config)#vtp mode server
 Device mode already VTP SERVER.
 S1(config)#vtp domain CISCO
 Changing VTP domain name from NULL to CISCO
 S1(config)#
 *Mar 1 00:14:20.226: %SW_VLAN-6-VTP_DOMAIN_NAME_CHG: VTP domain name changed to CISCO.
 S1(config)#!VLANs
 S1(config)#vlan 10
 S1(config-vlan)#name Red
 S1(config-vlan)#vlan 20
 S1(config-vlan)#name Blue
 S1(config-vlan)#vlan 30
 S1(config-vlan)#name Orange
 S1(config-vlan)#vlan 40
 S1(config-vlan)#name Green
 S1(config-vlan)#exit
 S1(config)#spanning-tree vlan 1,10,20,30,40 root primary

S3 – Ska även vara Secondary Root-bridge för samtliga vlan

Switch(config)#hostname S3
 S3(config)#line con 0
 S3(config-line)#logging sync
 S3(config-line)#!Trunk-links till S2
 S3(config-line)#int range fa0/1 - 2
 S3(config-if-range)#switchport trunk encaps dot1q
 S3(config-if-range)#switchport mode trunk
 S3(config-if-range)#channel-protocol lacp
 S3(config-if-range)#channel-group 1 mode active
 Creating a port-channel interface Port-channel 1
S3(config-if-range)#
 S3(config-if-range)#description to S2
 S3(config-if-range)#inte fa0/3
 % Command exited out of interface range and its sub-modes.
 Not executing the command for second and later interfaces
 S3(config-if)#!ISL-trunk till S1
 S3(config-if)#switchport trunk encaps ISL
 S3(config-if)#switchport mode trunk
 S3(config-if)#description ISL-trunk to S1
 S3(config-if)#!L3-port till S1
 S3(config-if)#int fa0/4
 S3(config-if)#no switchport
 S3(config-if)#ip add 172.16.13.3 255.255.255.0
 S3(config-if)#description L3-link to S1
 S3(config-if)#exit
 S3(config)#vtp mode client
 Setting device to VTP CLIENT mode.
 S3(config)#vtp domain CISCO
 Domain name already set to CISCO.
 S3(config)#spanning-tree vlan 1,10,20,30,40 root secondary

S2

Switch(config)#hostname S2
 S2(config)#line con 0
 S2(config-line)#logging sync
 S2(config-line)#!Etherchannels till S1 & S3
 S2(config-line)#inte range fa0/1 - 2
 S2(config-if-range)#switchport mode trunk
 S2(config-if-range)#description to S1
 S2(config-if-range)#channel-protocol lacp
 S2(config-if-range)#channel-group 1 mode passive
 Creating a port-channel interface Port-channel 1
S2(config-if-range)#int range fa0/3 - 4
 S2(config-if-range)#switchport mode trunk
 S2(config-if-range)#description to S3
 S2(config-if-range)#channel-protocol lacp
 S2(config-if-range)#channel-group 2 mode passive
 Creating a port-channel interface Port-channel 2
S2(config-if-range)#exit
 S2(config)#!VTP
 S2(config)#vtp mode client
 Setting device to VTP CLIENT mode.
 S2(config)#vtp domain CISCO
 Domain name already set to CISCO.
S2(config)#!Host-interface
 S2(config)#int range fa0/15 - 17
 S2(config-if-range)#switchport mode access
 S2(config-if-range)#switchport access vlan 10
 S2(config-if-range)#spanning-tree portfast
 S2(config-if-range)#int range fa0/19 - 20
 S2(config-if-range)#switchport mode access
 S2(config-if-range)#switchport access vlan 20
 S2(config-if-range)#spanning-tree portfast
 S2(config-if-range)#int range fa0/21-22
 S2(config-if-range)#switchport mode access
 S2(config-if-range)#switchport access vlan 30
 S2(config-if-range)#spanning-tree portfast
 S2(config-if-range)end

L3-Konfig

S1 – Kom ihåg att aktivera routing innan vi lägger in EIGRP-konfig

S1(config)#int lo0
 S1(config-if)#ip add 172.16.1.1 255.255.255.0
 S1(config-if)#!SVIs for VLANs
 S1(config-if)#int vlan 20
 S1(config-if)#ip add 172.16.20.1 255.255.255.0
 S1(config-if)#description Red
 S1(config-if)#int vlan 30
 S1(config-if)#ip add 172.16.30.1 255.255.255.0
 S1(config-if)#description Blue
 S1(config-if)#int vlan 40
 S1(config-if)#ip add 172.16.40.1 255.255.255.0
 S1(config-if)#description Green
 S1(config-if)#exit
 S1(config)#ip routing
 S1(config)#router eigrp 1
 S1(config-router)#network 172.16.0.0
 S1(config-router)#no auto
 S1(config-router)#no auto-summary

S3

S3(config)#int vlan 10
 S3(config-if)#ip add 172.16.10.3 255.255.255.0
 S3(config-if)#description Red
 S3(config-if)#int vlan 30
 S3(config-if)#ip add 172.16.30.3 255.255.255.0
 S3(config-if)#description Orange
 S3(config-if)#exit
 S3(config)#ip routing
S3(config-if)#!trunk to R3
S3(config-if)#int fa0/5
S3(config-if)#description trunk to R3
S3(config-if)#switchport mode trunk
S3(config-if)#switchport trunk allowed vlan 10,40

S2

S2(config)#int vlan 40 
S2(config-if)#ip add 172.16.40.2 255.255.255.0 
S2(config-if)#description Green

Då var all switch-konfig klar, endast routern kvar.. R3

Router(config)#hostname R3
 R3(config)#inte fa0/1
 R3(config-if)#description to S3-trunklink
 R3(config-if)#no shut
 R3(config-if)#inte fa0/1.10
 R3(config-subif)#encapsulation dot1q 10
 R3(config-subif)#ip add 172.16.10.200 255.255.255.0
 R3(config-subif)#inte fa0/1.40
 R3(config-subif)#encapsulation dot1q 40
 R3(config-subif)#ip add 172.16.40.200 255.255.255.0
 R3(config-subif)#exit
R3(config)#router eigrp 1
 R3(config-router)#network 172.16.0.0
 R3(config-router)#no auto-summary
 R3(config-router)#end

Verifiering – L3

S1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 6 subnets
C 172.16.40.0 is directly connected, Vlan40
C 172.16.30.0 is directly connected, Vlan30
C 172.16.20.0 is directly connected, Vlan20
C 172.16.13.0 is directly connected, FastEthernet0/4
D 172.16.10.0 [90/28416] via 172.16.40.200, 00:01:51, Vlan40
C 172.16.1.0 is directly connected, Loopback0
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 6 subnets
C 172.16.40.0 is directly connected, FastEthernet0/1.40
D 172.16.30.0 [90/28416] via 172.16.40.1, 00:02:35, FastEthernet0/1.40
D 172.16.20.0 [90/28416] via 172.16.40.1, 00:02:35, FastEthernet0/1.40
D 172.16.13.0 [90/30720] via 172.16.40.1, 00:02:35, FastEthernet0/1.40
C 172.16.10.0 is directly connected, FastEthernet0/1.10
D 172.16.1.0 [90/156160] via 172.16.40.1, 00:02:35, FastEthernet0/1.40
S1#ping 172.16.40.200
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/9 ms
S1#ping 172.16.10.200
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms
S1#ping 172.16.40.2
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
R3#ping 172.16.40.2
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

Verifiering L2

S3#sh interface trunk
Port Mode Encapsulation Status Native vlan
Fa0/3 on isl trunking 1
Fa0/5 on 802.1q trunking 1
Po1 on 802.1q trunking 1
Port Vlans allowed on trunk
Fa0/3 1-4094
Fa0/5 10,40
Po1 1-4094
S1#sh spanning-tree summary
Switch is in pvst mode
Root bridge for: VLAN0001, VLAN0010, VLAN0020, VLAN0030, VLAN0040
S2#sh etherchannel summary
Flags: D - down P - bundled in port-channel
 I - stand-alone s - suspended
 H - Hot-standby (LACP only)
 R - Layer3 S - Layer2
 U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
 u - unsuitable for bundling
 w - waiting to be aggregated
 d - default port

Number of channel-groups in use: 2
Number of aggregators: 2
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Fa0/1(P) Fa0/2(P) 
2 Po2(SU) LACP Fa0/3(P) Fa0/4(P)

Härligt! Stötte på lite problem under labben då det visade sig att interfacet jag tänkte använda mellan Switch & Router inte var directly connected. Det var inga problem att sätta upp trunkingen etc men trafiken fastnade i någon dold switch eller dylikt. Från början var det tänkt att Routern skulle vara ansluten till S2 men det fanns tyvärr inget interface att använda där som fungerade. Fick istället göra om ritningen lite och använda länken mellan R3-S3 men det fungerade ju precis lika bra efter lite mindre modifieringar. 🙂 Kul labb!

Switching – Etherchannel

Etherchannel ger oss möjlighet att aggregera redundanta länkar, och vi kan på så vis ta vara på all potentiell bandbredd istället för att länkarna ska blockeras av Spanning-tree. Nedanstående video från Keith Barker förklarar konceptet väldigt bra:

  • Interfacen som används måste ligga i samma VLAN alt. vara trunk-portar
  • Kan ej använda SPAN
  • Ändringar i det logiska port-channel interfacet påverkar alla portar i gruppen (channel-group)
  • Ändringar på enskilt interface återspeglas ej till gruppen, alla interface i gruppen måste ha identisk konfig!
  • Rekommenderat att konfigurera Speed & Duplex manuellt på samtliga länkar
  • Supportar länkhastigheter från 100M upp till 10 Gigabit
  • Etherchanneln kan användas som en L2 access-port, trunk, tunnel eller L3-interface

Etherchannel har stöd för att aggregera 2 till maximalt 8 aktiva länkar!

Protokoll

etherchannelprotocol

negotiation_modes

Som synes måste vi konfigurera Active eller Desirable på åtminstone en av switcharna för att det ska bildas en Etherchannel om vi använder oss av protokollen LACP eller PAgP.  Vi kan även “hårdkonfa” en Etherchannel utan att använda PAgP eller LACP via kommandot “channel-group x mode on”.

När vi konfigurerar Etherchannel rekommenderar Brian Dennis (CCIEx4) från INE att man alltid först stänger ner berörda interface för att undvika en del buggar som kan uppstå, detta är dock inget som nämns i Cisco materialet.

Port Aggregation Protocol (PAgP)

  • Cisco proprietärt
  • Använder channel-modes: desirable & auto

netlab

S1

S1(config)#int range fa0/3 - 4
S1(config-if-range)#shut
S1(config-if-range)#channel-protocol pagp
S1(config-if-range)#channel-group 1 mode desirable
S1(config-if-range)#no shut
Creating a port-channel interface Port-channel 1
*Mar 1 00:14:54.435: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up
*Mar 1 00:14:54.879: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to up

Observera dock att port-channel interfacet ej kom upp! Då vi konfade interfacet till desirable kommer S1 nu börja skicka PAgP-paket till S3, men den kommer inte skapa Etherchanneln förrän den fått svar.

S3

S3(config)#int range fa0/3 - 4
S3(config-if-range)#shut
S3(config-if-range)#channel-protocol pagp
S3(config-if-range)#channel-group 1 mode auto
S3(config-if-range)#no shut
Creating a port-channel interface Port-channel 1
*Mar 1 00:15:46.167: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to up
*Mar 1 00:15:46.285: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up
*Mar 1 00:15:52.039: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
*Mar 1 00:15:53.046: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up

S3 börjar nu svara på S1’s förfrågan om att skapa en Etherchannel och interfacet går därför upp både på S1 & S3, vilket tog cirka 7 sekunder i min topologi med 2st 3560’s.

 1#show etherchannel summary
 Flags: D - down P - bundled in port-channel
 I - stand-alone s - suspended
 H - Hot-standby (LACP only)
 R - Layer3 S - Layer2
 U - in use f - failed to allocate aggregator
 M - not in use, minimum links not met
 u - unsuitable for bundling
 w - waiting to be aggregated
 d - default port

Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) PAgP Fa0/3(P) Fa0/4(P)

Unikt för PAgP är även funktionen “non-silent“:

S3(config-if)#channel-group 1 mode desirable ?
 non-silent Start negotiation only after data packets received
S3(config-if)#channel-group 1 mode auto ?
 non-silent Start negotiation only after data packets received

Cisco ger följande rekommendationer för hur vi ska konfigurera detta:

  • Use the non-silent keyword when you connect to a device that transmits bridge protocol data units (BPDUs) or other traffic. Use this keyword with the auto or desirable mode. PAgP non-silent adds an extra level of link state detection because it listens for BPDUs or other traffic in order to determine if the link functions properly. This adds a form of UniDirectional Link Detection (UDLD) capability that is not available when you use the default silent PAgP mode.
  • Use the silent keyword when you connect to a silent partner (which is a device that does not generate BPDUs or other traffic). An example of a silent partner is a traffic generator that does not transmit packets. Use the silent keyword with auto or desirable mode. If you do not specify silent or non-silent, silent is assumed.
  • The silent mode does not disable the PAgP ability to detect unidirectional links. However, when you configure a channel, non-silent prevents a unidirectional port from even joining the link.
  • A PAgP configuration (the set port channel {desirable | auto} command) is safer than a non-PAgP configuration (the set port channel on command). A PAgP configuration provides protection for unidirectional links and also avoids misconfigurations that can arise when there are ports channeling on one side of the link and not on the other side.

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_tech_note09186a00800949c2.shtml#silent

Link Aggregation Control Protocol (LACP)

  • Öppen/Industri-standard, 802.3ad
  • Använder channel-modes: active & passive

LACP ger oss även möjligheten att lägga till totalt 16st interface i en “channel-group”. Etherchannel kommer fortfarande endast ha 8st aktiva interface, men skulle en av dessa länkar gå ner aktiveras istället någon av de andra åtta som står i standby-läge!

Vilken port som blir aktiv/standby bestäms efter “port priority-number” – lägst nummer = högst prio.  Består av 2 byte priority & 2 byte port-name, per default väljs de med lägst interface-nummer. Kan konfigureras via:

S3(config)#inte fa0/3
 S3(config-if)#lacp port-priority ?
 <0-65535> Priority value

Supportar 100M FastEthernet till 10 Gigabit – dvs vi kan få upp till (8x10Gb)x2=160Gb.

S1

 S1(config)#int range fa0/3 - 4
 S1(config-if-range)#shut
 S1(config-if-range)#channel-protocol lacp
 S1(config-if-range)#channel-group 1 mode active
 S1(config-if-range)#no shut

S3

 S3(config)#int range fa0/3 - 4
 S3(config-if-range)#shut
 S3(config-if-range)#channel-protocol lacp
 S3(config-if-range)#channel-group 1 mode passive
 S3(config-if-range)#no shut
 *Mar 1 00:30:56.205: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up
 *Mar 1 00:30:57.086: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to up
 *Mar 1 00:30:57.195: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
 *Mar 1 00:30:58.202: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up

Statisk

 S1(config)#int range fa0/3 - 4
 S1(config-if-range)#shut
 S1(config-if-range)#channel-group 1 mode on
 S1(config-if-range)#no shut
 S3(config)#int range fa0/3 - 4
 S3(config-if-range)#shut
 S3(config-if-range)#channel-group 1 mode on
 S3(config-if-range)#no shut
 S1#sh etherchannel summary
 Flags: D - down P - bundled in port-channel
 I - stand-alone s - suspended
 H - Hot-standby (LACP only)
 R - Layer3 S - Layer2
 U - in use f - failed to allocate aggregator
 M - not in use, minimum links not met
 u - unsuitable for bundling
 w - waiting to be aggregated
 d - default port
 Number of channel-groups in use: 1
 Number of aggregators: 1
 Group Port-channel Protocol Ports
 ------+-------------+-----------+-----------------------------------------------
 1 Po1(SU) - Fa0/3(P) Fa0/4(P)

Load-Balancing

Etherchannel ger oss även möjlighet att lastbalansera över länkarna, vilket förövrigt är per frame och inte per bit. Detta skiljer sig dock lite från vad vi är vana vid från andra protokoll som du kommer se längre ner. Vilket interface som skall användas bestäms från resultatet av en hashing-algoritm baserad på den load-balancing method vi använder oss av.

etherchannel-lb

Vilken som används per default är beroende av modell på switchen, 3560:n jag använder har stöd för följande metoder:

  • dst-ip Dst IP Addr
  • dst-mac Dst Mac Addr
  • src-dst-ip Src XOR Dst IP Addr
  • src-dst-mac Src XOR Dst Mac Addr
  • src-ip Src IP Addr
  • src-mac Src Mac Addr

Men använder src-mac per default, vi kan verifiera detta med kommandot “show etherchannel load-balance“.

S3#show etherchannel load-balance 
EtherChannel Load-Balancing Configuration:
 src-mac
EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source MAC address
 IPv4: Source MAC address
 IPv6: Source MAC address

Algoritmen fungerar som så att den tar “3 least significant bits”, och använder vi endast en parameter (src-mac) som i detta fall används görs inget mer.

netlab

För enkelhetens skull, säg att vi lastbalanserar mellan S1 & S3 över två fysiska länkar, och vi har två datorer med mac-adresserna aaaa.0000.0000 & bbbb.1111.1111 som är kopplade till S1. Vi Konverterar mac-adressen till binärt och tar de sista 3 bitarna:

aaaa.0000.0000 -> 3 Least significant bits = 000
bbbb.1111.1111 -> 3 Least significant bits = 001

S1 kommer även ge ett hash-värde för varje interface i channel-groupen (max 8):

Interface 1= 0
Interface 2 = 1

Interface 8 = 7

Om resultatet av hash-algoritmen blir 0 kommer trafiken skickas på Interface 1 (Fa0/3), om den blir 1 kommer trafiken gå över Interface 2 (Fa0/4).

Detta leder som du kanske förstår till en del problem. Skulle trafiken gå via en router kommer source mac alltid vara densamma, således kommer endast ett fysiskt interface att användas oavsett hur många vi har i vår etherchannel! Av denna anledning är det viktigt att tänka till vilken typ av trafik vi har och anpassa algoritmen så vi får en så stor spridning som möjligt. Tyvärr är det endast de riktigt dyra switcharna (Catalyst 6xxx) som klarar att lastbalansera baserat på Lager 4-information.

Vi konfigurerar detta med kommandot:

port-channel load-balance n

Om vi anger två parametrar för hashing-algoritmen, exempelvis src-mac & dest-mac, tas “3 least significant bits” från båda adresserna och switchen utför sedan istället en XOR-operation.

xor

Layer 3

När vi använder en MLS har vi även möjligheten att konfigurera vårat etherchannel till ett Lager 3-interface. Tillvägagångssättet är lite bakvänt men fortfarande väldigt basic.

S1

S1(config)#int range fa0/3 - 4
 S1(config-if-range)#shut
 S1(config-if-range)#exit
S1(config)#interface port-channel 5
 S1(config-if)#no switchport
 S1(config-if)#ip add 10.0.0.1 255.255.255.0
S1(config-if)#int range fa0/3 - 4
 S1(config-if-range)#no switchport
 S1(config-if-range)#channel-group 5 mode desirable
 S1(config-if-range)#channel-protocol pagp
 S1(config-if-range)#no shut

S3

S3(config)#int range fa0/3 - 4
 S3(config-if-range)#shut
 S3(config-if-range)#exit
S3(config)#interface port-channel 5
 S3(config-if)#no switchport
 S3(config-if)#ip add 10.0.0.2 255.255.255.0
S3(config-if)#int range fa0/3 - 4
 S3(config-if-range)#no switchport
 S3(config-if-range)#channel-group 5 mode auto
 S3(config-if-range)#channel-protocol pagp
 S3(config-if-range)#no shut

Verifiering

S3(config-if-range)#do ping 10.0.0.1
Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/9 ms